Cannot access data on license card

Questions for the South African Civil Aviation Authority.

Moderator: Moderators

Valvebounce73
Preflighting
Posts: 20
Joined: Tue Feb 03, 2015 6:38 pm
Closest Airfield: FAFK
Location: Cape Town
Has liked: 0
Been liked: 0

Cannot access data on license card

Unread post by Valvebounce73 » Mon Jan 31, 2022 3:18 pm

Hi,
I recently received my license on the card system, but cannot scan the barcode. If I go to the e-services link though to register, it says ‘Insufficient data for self-registration. Please contact the system administrator.’
Can anybody assist? This is an RPL License.

Thanx
Kootenayflyer
Engine Cranking
Posts: 45
Joined: Fri Oct 21, 2016 11:03 pm
Closest Airfield: FAVG
Location: Toti
Has liked: 24 times
Been liked: 6 times

Re: Cannot access data on license card

Unread post by Kootenayflyer » Tue May 10, 2022 5:45 pm

Have the same issue, but with the PPL. Finally received the CC size license, but there is zero information other than a picture, the license number and the rating. The bar code still does not work and I am so can not register on the CAA web site.
What a joke…..
Laurent
ZS-LEW
User avatar
MaverickKevin
Rolling
Posts: 155
Joined: Sun Jun 09, 2013 1:30 pm
Closest Airfield: FAKR
Location: Krugersdorp
Has liked: 32 times
Been liked: 18 times

Re: Cannot access data on license card

Unread post by MaverickKevin » Fri May 13, 2022 8:51 am

Its enough to drive you insane ,I tried to do a H&F that obviously required validation. I tried this with the new CC license and ran into a brick wall because it refused to send me the OTP ... eventually out of sheer desperation read the FAQs and found out there is a backup link:

http://e-services.caa.co.za/webclient/index

I hope it works for RPLs,let us know!
Remember- the mags are always hot, the oil cap is always loose ...

Aviate Navigate Communicate!
thomassage
Preflighting
Posts: 22
Joined: Wed Jul 08, 2015 3:59 pm
Closest Airfield: FAVG
Location: Durban
Has liked: 1 time
Been liked: 0

Re: Cannot access data on license card

Unread post by thomassage » Tue May 17, 2022 9:27 am

Hi All

I had the same problem trying to register myself receiving the same error. It turns out I had missed a step.

I reached out to CAA client services on email, took them 2 days to respond, they understood the problem and sent me a new activation email. The email specifies the user name for you, you don't get to choose and then you select a password. Once saved you can log in and access all the info. It seems the self registration does not work. You must activate from an email received from CAA.

Hope that helps anyone who has perhaps missed that step and trying to get on with the self registration. The address I used was ClientCare@caa.co.za

Return to “CAA General Questions”